Network_Automation
Devices Configs

These are the configurations for my lab:

CSR1:

en
conf t 
line con 0
logging syn
exec-timeo 0 0
hostn CSR1
ip domain name cisco
line vty 0 4
login local
transport inp ssh
username admin priv 15 secret cisco123
enable secret cisco123
no ip http server
ip http authentication local
ip http secure-server
ip http client source-interface GigabitEthernet1
ip domain name hwtech.com
crypto key gen rsa mo 1024
int g1
ip add 192.168.1.202 255.255.255.0
no shut
ip route 0.0.0.0 0.0.0.0 192.168.1.254
end 
write

CSR2:

en
conf t 
line con 0
logging syn
exec-timeo 0 0
hostn CSR2
ip domain name cisco
line vty 0 4
login local
transport inp ssh
username admin priv 15 secret cisco123
enable secret cisco123
no ip http server
ip http authentication local
ip http secure-server
ip http client source-interface GigabitEthernet1
ip domain name hwtech.com
crypto key gen rsa mo 1024
int g1
ip add 192.168.1.203 255.255.255.0
no shut
ip route 0.0.0.0 0.0.0.0 192.168.1.254
end 
write

iosv_R1:

en
conf t 
line con 0
logging syn
exec-timeo 0 0
hostn iosv_R1
ip domain name cisco
line vty 0 4
login local
transport inp ssh
username admin priv 15 secret cisco123
enable secret cisco123
no ip http server
ip http authentication local
ip http secure-server
ip http client source-interface g0/0
ip domain name hwtech.com
crypto key gen rsa mo 1024
int g0/0
ip add 192.168.1.204 255.255.255.0
no shut
ip route 0.0.0.0 0.0.0.0 192.168.1.254
end 
write

For the Juniper devices we are using VSRx so we will turn it into a router with the following commands and then configure it:

juniper_r1:

configure
delete security 
set security forwarding options family mpls mode packet-based
set security forwarding options family inet6 mode packet-based
set security forwarding options family iso mode packet-based
delete chassis auto-image 
set system services ssh
set system login user admin class super-user
set interface fxp0 unit 0 family inet address 192.168.1.200/24
set system host-name juniper_r1
set system root-authentication plain-text-password
set system login user admin authentication plain-text-password
Juniper123
Juniper123
commit and-quit comment "Initial config" 

juniper_r2:

configure
delete security 
set security forwarding options family mpls mode packet-based
set security forwarding options family inet6 mode packet-based
set security forwarding options family iso mode packet-based
delete chassis auto-image 
set system services ssh
set system login user admin class super-user
set interface fxp0 unit 0 family inet address 192.168.1.201/24
set system host-name juniper_r2
set system root-authentication plain-text-password
juniper123
juniper123
set system login user admin authentication plain-text-password
juniper123
juniper123
commit and-quit comment "Initial config"