CCNP-Studies
Routing
5-VRF-Lite
3 Configurations

These are the configurations for each device in our VRF Lite topology:

R2

conf t
int e0/2
 description Link to SW1 e0/0 Inside VRF-BLUE on SW1 VLAN 12
 ip add 172.16.2.2 255.255.255.0
 no shut
!
router eigrp 1
 passive-interface default
 no passive-interface e0/2
 network 0.0.0.0

R3

conf t
int e0/2
 description Link to SW1 e0/1 Inside VRF-RED on SW1 VLAN 13
 ip add 172.16.3.3 255.255.255.0
 no shut
!
router eigrp 1
 passive-interface default
 no passive-interface e0/2
 network 0.0.0.0

R4

conf t
int e0/2
description Link to SW1 VRF-RED DC
 ip add 10.1.4.4 255.255.255.0
 no shut
!
router eigrp 1
 network 0.0.0.0

R5

conf t
int e0/2
 description Link to SW1 VRF-RED DC
 ip add 10.1.5.5 255.255.255.0
 no shut
!
router eigrp 1
 network 0.0.0.0

SW1

conf t
!
vrf definition BLUE
 rd 1:4
 address-family ipv4
!
vrf definition Purple
 rd 1:1
 address-family ipv4
!
vrf definition RED
 rd 1:5
 address-family ipv4
!
int e0/2
 no switchport
 vrf forwarding RED
 ip add 10.1.5.1 255.255.255.0
 description Link to R5
!
int e0/3
 no switchport
 vrf forwarding BLUE
 ip add 10.1.4.1 255.255.255.0
 description Link to R4
!
interface Vlan12
 description VRF-BLUE Link to R3 Internet Traffic
 vrf forwarding BLUE
 ip address 172.16.2.1 255.255.255.0
!
int vlan 13
 description VRF-BLUE Link to R3 DC Traffic
 vrf forwarding RED
 ip add 172.16.3.1 255.255.255.0
 no shut
!
int l0
 vrf forwarding PURPLE
 ip add 172.16.1.1 255.255.255.0
!
int e0/0
 description VRF-BLUE Internet traffic
 switchport mode access
 switchport access VLAN 12
int e0/1
 description VRF-RED DC traffic
 switchport mode access
 switchport access VLAN 13
!
router eigrp VRF
 address-family ipv4 unicast vrf RED autonomous-system 1
 network 0.0.0.0
 topology base
 redistribute bgp 65000 metric 10000 10 255 1 1500
!
exit
!
address-family ipv4 unicast vrf BLUE autonomous-system 1
network 0.0.0.0
topology base
redistribute bgp 65000 metric 10000 10 255 1 1500
!
address-family ipv4 unicast vrf PURPLE autonomous-system 1
network 0.0.0.0
topology base
redistribute BGP 65000 metric 10000 10 255 1 1500
!
router bgp 65000
bgp router-id 1.1.1.1
address-family ipv4 vrf BLUE
redistribute connected
redistribute eigrp 1
!
exit
!
address-family ipv4 vrf PURPLE
redistribute connected
redistribute eigrp 1
!
address-family ipv4 vrf RED
redistribute connected
redistribute eigrp 1
!

Importing and Exporting Route-Targets

vrf definition BLUE
route-target both 1:4
!
vrf definition RED
route-target both 1:5
route-target import 1:1 # This will import PURPLE VRFs into the RED VRF
!
vrf definition PURPLE
route-target both 1:1
route-target import 1:5 # This will import RED VRFs into the PURPLE VRF