CCNP-Studies
Routing
3-Policy-Based-Routing-(PBR)
3 Configs

Here are the Configs:

R2 config:

en
conf t
int e0/2
ip add 10.0.12.2 255.255.255.0
no shut
ip route 0.0.0.0 0.0.0.0 10.0.12.1

R3 config:

en
conf t
int e0/2
description guest Wi-Fi
ip add 10.0.13.3 255.255.255.0
no shut
ip route 0.0.0.0 0.0.0.0 10.0.13.1

R4 config:

en
conf t
ip route 0.0.0.0 0.0.0.0 10.24.35.1

R5 config:

en
conf t
ip route 0.0.0.0 0.0.0.0 10.24.35.1

Core-SW1 config:

en
conf t
ip routing
ip route 0.0.0.0 0.0.0.0 10.24.35.4
!
int vlan 1
description SVI Link to R4 and R5
ip add 10.24.35.1 255.255.255.0
no shut
!
int vlan 12
description SVI Link to R2
ip add 10.0.12.1 255.255.255.0
no shut
!
Int e0/0
Switchport mode access
Switchport access vlan 12
!
Vlan 13
Name Guest Wi-Fi
!
Int vlan 13
Description Guest Wi-Fi SVI
Ip add 10.0.13.1 255.255.255.0
No shut
!
Int e0/1
Switchport mode access
Switchport access vlan 13
!
! Extended ACL
ip access-list extended GUEST-R5
permit ip 10.0.13.0 0.0.0.255 any
exit
!
! Route-map (PBR)
!
! Configure the route map
!
route-map GUEST-R5 permit
 match ip address GUEST-R5 permit
 set ip next-hop 10.24.35.5
!
! Applying the policy to the interface
!
Interface vlan 13
Ip policy route-map GUEST-R5
!
end
!
wr